Update on Product Listing Enhancements

Incident Report for Second Life

Monitoring

We want to apologize for an issue that affected Product Listing Enhancement (PLE) charges on the Second Life Marketplace earlier this month.

Between October 8th and October 28th, the system responsible for billing PLEs did not process charges as expected. When the issue was corrected on October 28th, charges for that entire period were processed all at once.

We understand this may have caused confusion and inconvenience. We're very sorry for the disruption. Our teams have identified the underlying cause and are working to ensure the billing system remains stable and accurate moving forward.

This follows an earlier issue in August, when some users were charged incorrectly. We know that repeated billing issues are frustrating, and we take them seriously. We're continuing to improve our monitoring and safeguards to prevent similar incidents in the future.

Thank you for your patience and continued support as we work to make the Marketplace more reliable for everyone.
Posted Oct 30, 2025 - 13:12 PDT