Second Life Login Issues
Incident Report for Second Life
Resolved
This incident has been resolved. If you are still unable to log in, please download the latest viewer from https://get.secondlife.com and try logging in with that. On the off chance you are still having trouble, please contact support, and they will work with you to resolve any issues.
Posted Nov 01, 2022 - 14:57 PDT
Investigating
We are investigating reports that some Residents may be encountering errors when attempting to log into Second Life with the viewer. If you encounter this, please first try logging into secondlife.com and accepting the new Terms of Service, then try logging into the viewer again. Please follow this blog for updates.
Posted Oct 31, 2022 - 11:35 PDT
This incident affected: Second Life Services (Logins).