Unscheduled Marketplace Maintenance
Incident Report for Second Life
Resolved
Today's unscheduled Second Life Marketplace maintenance is now complete. Please feel free to resume transacting on the Marketplace.
Posted 3 months ago. May 20, 2019 - 15:43 PDT
Investigating
We are currently undergoing unscheduled Second Life Marketplace maintenance. Transactions may not be updating, deliveries may be delayed and all other Marketplace information may not be updating in a timely fashion. We ask that you please refrain from making Marketplace purchases until this maintenance is complete. Please check this post for updates.
Posted 3 months ago. May 20, 2019 - 14:55 PDT
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (Marketplace Purchases).