Unscheduled Maintenance to Concierge and Billing Phone Support

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Dec 08, 2021 - 05:44 PST

Investigating

We are aware our Concierge and Billing phone lines are currently inaccessible and are working to restore them. Premium Live Chat and ticket submissions are still available. Thank you for your patience, and please follow this blog for updates.
Posted Dec 07, 2021 - 09:41 PST
This incident affected: External Support (Phone Support).