Marketplace and LindeX Issues

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Mar 25, 2024 - 06:36 PDT

Investigating

We are aware that some Residents may be having trouble receiving LindeX and Marketplace orders. We are actively investigating these issues. Please follow this blog for updates.
Posted Mar 24, 2024 - 14:47 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).