Unscheduled Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 08:29 PDT
Investigating
In-world content that uses outbound web connections (such as vendor servers or other objects using HTTP) may be experiencing connection issues at this time due to service problems with a third party provider. We are currently investigating this issue. Please watch this blog for updates
Posted Sep 18, 2023 - 18:28 PDT