My.secondlife.com Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Feb 01, 2023 - 15:45 PST
Investigating
My.secondlife.com is currently undergoing maintenance. Residents may experience slow load times while viewing web profiles.

Please monitor the blog for updates.
Posted Jan 31, 2023 - 10:53 PST
This incident affected: Websites (my.secondlife.com).