Scheduled Second Life Profile Maintenance
Incident Report for Second Life
Resolved
Maintenance is complete and profiles are now available. Thank you for your patience!
Posted Nov 17, 2020 - 16:10 PST
Investigating
Our Second Life Profiles will temporarily be under maintenance until further notice. During this time, both inworld and my.secondlife.com profiles will be unavailable. Please watch this blog for updates.
Posted Nov 17, 2020 - 14:20 PST
This incident affected: Inworld Services (Profiles) and Websites (my.secondlife.com).