Unscheduled Second Life Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance is complete and logins should now be available. Thank you for your patience!
Posted 25 days ago. Nov 18, 2017 - 07:11 PST
Investigating
Greetings, residents! We are aware that there may be an issue with Second Life logins at this time. We are actively investigating this issue, and will provide updates via this blog. Thank you for your patience as we work to resolve this.
Posted 25 days ago. Nov 18, 2017 - 05:26 PST
This incident affected: Second Life Services (Logins).