Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been completed.
Posted 21 days ago. Oct 30, 2017 - 11:56 PDT
Investigating
We are performing unscheduled maintenance at this time. While this maintenance is in progress, our billing services, including LindeX and Marketplace, may not be available. Credit card processing may be affected during this time as well. Please check this blog for updates. Edit
Posted 21 days ago. Oct 30, 2017 - 11:42 PDT
This incident affected: Second Life Regions (Second Life Main Channel Regions, Second Life RC LeTigre Regions, Second Life RC BlueSteel Regions, Second Life RC Magnum Regions, Second Life RC Snack Regions, Second Life RC Cake Regions) and Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).