Planned In-World Voice and Chat Maintenance

Scheduled for Jul 21, 15:30 - 16:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 21, 2026 - 09:52 PDT

Update

We have updated the time for our scheduled maintenance at this time
Posted Jul 21, 2026 - 09:50 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 21, 2026 - 09:44 PDT

Scheduled

Starting at 3:30 PM SLT on 7-21-2026, we will be performing maintenance to our voice servers. Private, Conference, and Group Voice and Chat may not function correctly during this time.

We appreciate your patience while this maintenance is performed and will update the blog once maintenance has been completed.
Posted Jul 21, 2026 - 09:10 PDT
This scheduled maintenance affects: Inworld Services (Group Text Chat, Voice Chat, Group Voice Chat).