Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
We have completed the unscheduled maintenance on our billing system. Thank you for your patience during this time!
Posted Jan 08, 2021 - 15:25 PST
Investigating
We are performing an unscheduled maintenance on our billing system. At this time, Residents may be unable to use the cashier or to make purchases, and some purchases may take longer than normal to process. Please watch this blog for updates.
Posted Jan 08, 2021 - 14:08 PST
This incident affected: Second Life Services (LindeX Purchases).