Extended Community Maintenance
Incident Report for Second Life
Resolved
The maintenance has been completed.
Posted 3 months ago. Mar 29, 2019 - 14:28 PDT
Investigating
We are still performing maintenance on our Community pages, today. While this maintenance is in progress, Community pages (including Blogs and Forums) may not be accessible. Please check this blog for updates.
Posted 3 months ago. Mar 29, 2019 - 08:20 PDT
This incident affected: Websites (community.secondlife.com, my.secondlife.com, places.secondlife.com).