Premium Stipends Delayed
Incident Report for Second Life
Resolved
We have resolved the issue causing delayed Stipends for Premium members. Thank you for your patience!
Posted Jul 07, 2020 - 15:44 PDT
Update
We have resolved the issue causing delayed Stipends for Premium members. Thank you for your patience!
Posted Jul 07, 2020 - 15:44 PDT
Investigating
We are aware the Stipends for this week have been delayed for some Premium members. We are investigating the issue, and expect them to be paid out soon. Please monitor this blog for updates.
Posted Jul 07, 2020 - 08:45 PDT