Phone Support Unavailable
Incident Report for Second Life
Resolved
This issue has been resolved and phone support is once again operational. Thank you for your patience while we resolved this issue.
Posted 29 days ago. Jun 26, 2017 - 10:17 PDT
Investigating
Our telephone service provider is experiencing temporary technical issues. During this outage, Concierge Phone Support will remain unavailable. We apologize for this inconvenience. Please monitor this blog for additional updates.
Posted 29 days ago. Jun 26, 2017 - 09:49 PDT
This incident affected: External Support (Phone Support).