Second Life Name Change Service Maintenance
Incident Report for Second Life
Resolved
The maintenance has been completed.
Posted Oct 04, 2023 - 09:22 PDT
Update
We are continuing to investigate this issue.
Posted Oct 04, 2023 - 09:07 PDT
Investigating
We will be performing maintenance on our Name Change services on Wednesday, October 4th at 9am PST. While this maintenance is in progress, Residents may be unable to use the automated name change service. Please watch this blog for updates.
Posted Oct 04, 2023 - 09:06 PDT
This incident affected: Websites (secondlife.com).