Unscheduled Support Maintenance
Incident Report for Second Life
Resolved
The unscheduled support maintenance has been completed. All support services are now available once more.
Posted 7 months ago. May 30, 2018 - 10:49 PDT
Investigating
We are currently undergoing unscheduled support services maintenance. Live Chat support may not be available until the maintenance is complete. Case submission, and telephonic support where applicable, is still available, however.
Posted 7 months ago. May 30, 2018 - 09:57 PDT
This incident affected: External Support (Chat Support) and Websites (support.secondlife.com).