Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
This matter has now been resolved. Please contact Support if you continue to experience errors while attempting to add a credit/debit card to your payment methods.
Posted 5 days ago. Oct 10, 2019 - 20:32 PDT
Investigating
We are currently investigating an issue with adding a credit card.
Posted 5 days ago. Oct 10, 2019 - 19:02 PDT