Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Apr 23, 2023 - 23:55 PDT
Investigating
We are currently undergoing maintenance to our billing systems. Residents may experience a longer wait time than usual when making purchases, buying or selling L$, or when using the cashier at this time. Please watch this blog for updates.
Posted Apr 23, 2023 - 23:21 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).