Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved. Please contact Support if you have any questions or concerns regarding this incident. Thank you for your patience and understanding.
Posted Jan 03, 2019 - 15:54 PST
Investigating
We are currently performing unscheduled billing maintenance. While this maintenance is in progress, some users may experience failed transactions or be unable to add credit cards as payment methods. Please watch this blog for further updates.
Posted Jan 03, 2019 - 10:16 PST
This incident affected: Second Life Services (LindeX Purchases).