Unscheduled Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Sep 07, 2023 - 18:10 PDT
Investigating
We are currently investigating an issue with the email subscriptions page on accounts.secondlife.com. Please watch this blog for updates.
Posted Sep 07, 2023 - 17:25 PDT