Unscheduled LindeX Maintenance

Incident Report for Second Life

Update

We are continuing to investigate this issue.
Posted Jun 25, 2026 - 14:14 PDT

Investigating

We're currently investigating issues with Second Life billing services, which may include buying or selling Linden dollars (L$) on the Linden Exchange (LindeX), completing US Dollar transactions, purchasing regions from the Land Store, or other financial transactions.

Please monitor this blog for additional updates as our investigation continues.
Posted Jun 25, 2026 - 12:39 PDT
This incident affects: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits) and Inworld Services (L$ Transactions).