Unscheduled Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Nov 01, 2019 - 12:00 PDT
Investigating
We are currently investigating an issue that has affected access to a number of regions. Residents may experience difficulty in reaching certain regions. Please follow this blog for updates.
Posted Nov 01, 2019 - 10:44 PDT
This incident affected: Second Life Regions (Second Life Main Channel Regions, Second Life Release Candidate Regions).