Login Trouble Surrounding Europe

Incident Report for Second Life

Resolved

This issue has been resolved.
Posted May 01, 2020 - 14:51 PDT

Update

We are continuing to investigate this issue.
Posted May 01, 2020 - 13:41 PDT

Investigating

We are aware of connectivity issues with residents unable to login from the UK region. We are monitoring the issue and will update this blog as it develops.
Posted May 01, 2020 - 13:41 PDT