Unscheduled Maintenance for Community.secondlife.com
Incident Report for Second Life
Resolved
The scheduled maintenance has been completed.
Posted 3 months ago. Aug 29, 2017 - 14:05 PDT
Investigating
We are undergoing scheduled maintenance to our Community website. During this maintenance, Residents may not be able to access our Community page or post forums. Please keep an eye on this blog for updates.
Posted 3 months ago. Aug 29, 2017 - 11:46 PDT
This incident affected: Websites (community.secondlife.com).