Second Life Marketplace and Billing Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 26 days ago. Feb 23, 2019 - 08:53 PST
Investigating
We are currently investigating issues regarding the delivery of Marketplace transactions as well as Linden Dollars purchased. Transactions made should appear as soon as the issue is resolved. Please keep an eye on this blog for any updates.
Posted 26 days ago. Feb 23, 2019 - 08:33 PST
This incident affected: Websites (marketplace.secondlife.com), Inworld Services (L$ Transactions), and Second Life Services (LindeX Purchases, Marketplace Purchases).