Phone and Chat Support Unavailable
Incident Report for Second Life
Resolved
Phone and chat support are open again.
Posted 2 months ago. Apr 21, 2017 - 12:59 PDT
Identified
Phone and chat support will be unavailable from 12:00 noon to 1:00 PM PDT, April 21, 2017. Case submissions are still available.
Posted 2 months ago. Apr 21, 2017 - 11:43 PDT
This incident affected: External Support (Chat Support, Phone Support).