Phone and Chat Support Unavailable
Incident Report for Second Life
Resolved
Phone and chat support are now available.
Posted 5 months ago. Apr 17, 2017 - 06:17 PDT
Investigating
Phone and chat support will be unavailable from 3:00 PM April 15th, 2017 to 5:00 AM PDT, April 17th, 2017. Case submissions are still available.
Posted 5 months ago. Apr 15, 2017 - 15:20 PDT
This incident affected: External Support (Chat Support, Phone Support).