Parcel Traffic Number Issues

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Sep 15, 2021 - 13:03 PDT

Investigating

We are aware of an issue that may be affecting some parcel traffic numbers at this time. We appreciate your patience while we are investigating for a resolution in this matter. Please follow this blog for any further updates.
Posted Sep 15, 2021 - 10:49 PDT