Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance is complete.

Thank you for your patience during this time.
Posted about 1 month ago. Apr 20, 2018 - 22:37 PDT
Investigating
We are currently performing unscheduled maintenance. While this maintenance is in progress, our billing services, including LindeX and Marketplace, may not be available. Payments, purchases, Process Credits, L$ transactions and adding Payment Methods may be impacted.

Please check this blog for updates.
Posted about 1 month ago. Apr 20, 2018 - 22:30 PDT