Labor Day Observance - Support Closed
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 04, 2018 - 05:55 PDT
Investigating
Concierge and Billing Phone Support and Live Chat will be closed on Monday, September 3rd in observance of Labor Day. Ticket submission will remain available. Have a happy and safe holiday!
Posted 2 months ago. Sep 03, 2018 - 09:01 PDT
This incident affected: External Support (Chat Support, Phone Support).