Second Life Support Outage

Incident Report for Second Life

Update

We are continuing to investigate this issue.
Posted Aug 23, 2026 - 12:10 PDT

Investigating

We are currently investigating the outage of our Support services. At this time residents may experience issues accessing their dashboard on Second Life, logging inworld, and the ability to access Live Chat or to submit a Support case. We greatly apologize for this inconvenience. Please follow this blog for any further updates.
Posted Aug 23, 2026 - 12:06 PDT
This incident affects: Websites (secondlife.com, marketplace.secondlife.com, community.secondlife.com, my.secondlife.com, support.secondlife.com), Second Life Services (Logins, LindeX Purchases, Marketplace Purchases), Inworld Services (Group Text Chat, L$ Transactions, Rezzing, Voice Chat, Profiles, Teleports, Inventory, Group Voice Chat), and External Support (Chat Support, Case Support).