Add Payment Method Issues for Non-US Residents
Incident Report for Second Life
Resolved
This incident has been resolved and new payment methods can be added once again
Posted 4 months ago. Apr 22, 2019 - 05:35 PDT
Investigating
Adding new payment methods temporarily unavailable for non-US residents. While issue present, some non-US residents may experience problems adding a new method of payment to their Second Life account. Transactions using preexisting stored methods of payment appear to be unaffected.

Please monitor this blog for additional updates
Posted 4 months ago. Apr 22, 2019 - 04:42 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).