Dashboard Pages May Fail to Load
Incident Report for Second Life
Resolved
We believe this issue is resolved, though we are continuing to monitor the situation. If you discover that you still experiencing issues on the Dashboard, you may need to log out once more, then log back in.
Posted Jan 06, 2022 - 11:49 PST
Investigating
We are aware of an issue in which multiple pages on the Second Life Dashboard may fail to load properly, and we are investigating this matter further.

As a temporary workaround, please note that this issue can often be fixed by logging out of the dashboard, then logging back in. Please be certain to select the "Log Out" link from the dashboard, as this link ends your current session and is very important for this solution to work.

Thank you for your patience! Please follow this blog for further updates.
Posted Jan 04, 2022 - 08:51 PST
This incident affected: Websites (secondlife.com).