Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Mar 30, 2022 - 23:43 PDT
Investigating
We are currently undergoing unscheduled maintenance on our billing systems. Residents may be unable to use the cashier or to make purchases. They may also see failed delivery on recent LindeX purchases, Marketplace purchases, and Quickbuys. Please follow this blog for updates.
Posted Mar 30, 2022 - 17:50 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).