Viewer 5.1.5.515811 Update Issues for 5/31/2018
Incident Report for Second Life
Resolved
The issue impacting 32 bit Windows users who attempted to update to Viewer 5.1.5.515811 has been resolved
Posted 4 months ago. Jun 21, 2018 - 15:08 PDT
Identified
We are currently aware of an issue where 32 bit Windows users are unable to update to the latest version of Second Life. For more information on how to resolve the issue and free yourself from an update loop please view this post on the Community page:

https://community.secondlife.com/forums/topic/423151-viewer-515515811-release-issues-for-5312018/

We thank you for your patience during this time and apologize for the inconvenience.
Posted 5 months ago. Jun 01, 2018 - 17:20 PDT