Stipend Payments Delayed
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Feb 18, 2025 - 11:35 PST
Investigating
We are aware of an issue where weekly stipend payments to Premium and Premium Plus members may have been delayed. We are currently investigating the issue. Please keep an eye on this blog for any updates.
Posted Feb 18, 2025 - 09:11 PST