Premium Stipends Delayed
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Apr 28, 2020 - 12:49 PDT
Investigating
We are aware the Stipends have been delayed for some Premium members. We are investigating and expect them to be paid out soon. Please monitor this blog for updates.
Posted Apr 28, 2020 - 08:16 PDT