Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 19:53 PST
Investigating
We are performing unscheduled maintenance on our billing system. At this time, Residents may be unable to use the cashier or to make purchases, and some purchases may take longer than normal to process. Please watch this blog for updates.
Posted Nov 24, 2020 - 18:23 PST
This incident affected: Second Life Services (LindeX Purchases) and Websites (marketplace.secondlife.com).