CasperVend Issues

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jul 20, 2023 - 23:35 PDT

Investigating

We've received reports that Casper vendors are unresponsive, and we're currently looking into it. Please check this blog for updates
Posted Jul 20, 2023 - 22:15 PDT