Second Life Auction Page Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 6 days ago. May 15, 2018 - 09:00 PDT
Investigating
We are currently undergoing unscheduled maintenance to our Auctions - Second Life website. At this time, residents will not be able to access the Mainland Land Auctions page. Please keep an eye on this blog for further updates as they become available.
Posted 6 days ago. May 15, 2018 - 07:21 PDT