Unscheduled Marketplace Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jan 21, 2020 - 11:38 PST

Investigating

We are currently performing maintenance to the Marketplace. During this maintenance, residents may be unable to access the Marketplace. Please watch this blog for updates.
Posted Jan 21, 2020 - 10:04 PST
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (Marketplace Purchases).