Phone and Chat Support Unavailable
Incident Report for Second Life
Resolved
Phone and chat support are now open.
Posted 7 months ago. Apr 14, 2017 - 13:00 PDT
Investigating
Phone and chat support will be unavailable from 12:00 noon to 1:00 PM PDT, April 14th, 2017. Case submissions are still available.
Posted 7 months ago. Apr 14, 2017 - 11:41 PDT
This incident affected: External Support (Chat Support, Phone Support).