Unscheduled Second Life Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance is now complete.
Posted May 21, 2018 - 06:55 PDT
Update
We are also aware that some residents are receiving a message that their login credentials are incorrect. Please be patient when logging in, and we will update this post as soon as we have more information.
Posted May 21, 2018 - 06:24 PDT
Investigating
We are aware that there may be intermittent issues with Second Life logins at this time. We are actively investigating the issue, and will provide updates via this blog. Please contact Support if you experience any difficulty with any purchases made during this time.
Posted May 21, 2018 - 06:08 PDT
This incident affected: Second Life Services (Logins, LindeX Purchases, Marketplace Purchases, Process Credits).