Unscheduled Phone Support Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Nov 25, 2020 - 14:13 PST

Investigating

We are currently experiencing an issue with phone support. Chat support and ticket submissions will still be available during this time. Please keep an eye on this blog for updates.
Posted Nov 25, 2020 - 10:53 PST
This incident affected: External Support (Phone Support).