Brief Delay to Support Hours This Morning

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 06:45 PDT

Investigating

Support will open 15 minutes later than usual this morning while our team wraps up a scheduled team-building session.

Phone and live chat will be unavailable during this time. We expect both to be back up within 15 minutes. Ticket submissions are still available.

Thank you for your patience.
Posted Sep 16, 2026 - 06:34 PDT
This incident affected: External Support (Chat Support, Phone Support).