Scheduled Maintenance - Bake Service Update
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted about 1 month ago. Jan 14, 2019 - 18:23 PST
Investigating
We're floating a new update to help you get back on the ground! You may encounter issues changing outfits during this time.

Once the update has completed, any avatars experiencing issues with hover height will need to change outfits in order to help you stand on the ground.
Posted about 1 month ago. Jan 14, 2019 - 17:12 PST