Marketplace Order Delivery Delays

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Jan 06, 2025 - 11:48 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 18, 2024 - 08:53 PST

Investigating

We are aware that some users are experiencing delays in receiving deliveries from purchased goods on the Marketplace. Our engineers are aware of the issues, and are investigating for cause.

Please keep an eye on this blog for updates.
Posted Dec 17, 2024 - 12:26 PST
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (Marketplace Purchases).