Unscheduled Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 25, 2019 - 20:23 PDT
Identified
Our engineers have identified the issue and are working to resolve it.
Posted 3 months ago. Mar 25, 2019 - 19:57 PDT
Investigating
Second Life is currently undergoing unscheduled maintenance. This may result in troubles logging on or using inworld services. Please watch this blog for further information.
Posted 3 months ago. Mar 25, 2019 - 19:44 PDT
This incident affected: Second Life Services (Logins) and Inworld Services (Teleports, Inventory).