Unscheduled Maintenance on Live Chat

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Aug 09, 2021 - 12:50 PDT

Investigating

We are currently performing unscheduled maintenance on Live Chat. While this maintenance is in progress, Live Chat will be unavailable. Phone and support tickets are still available at this time. Please watch this post for updates.
Posted Aug 09, 2021 - 11:00 PDT
This incident affected: External Support (Chat Support).